DWQA QuestionsCategory: PiCapture SupportRe: Unable to Use Serial
Manu asked 2 months ago

Hi,
I was able to fix the splitting bar issue by setting the camera to 1080p. However I still have the colour problem. When the camera’s hdmi output is connected straight to the monitor, the colours are fine. However when it is put through PiCapture, it is not.
I use the following commands to check whether it’s my code’s issue or not.
‘raspivid -d’ and ‘raspistill -d’ both are overexposed and have reddish tint.
My ‘pivideo -q all -v’ output is as follows,
PiVideo Version 1.13
Port used for video processor is: i2c1
PiCapture HD1 is ready
Active video: Mode 1
Selected video source is: auto
Active video source is: hdmi
Raspberry Pi camera port is not active
Frame skip is Off
Video processor firmware version: 07-87C103
Video processor hardware id: C4C84E0820829880

1 Answers
mwlinder Staff answered 2 months ago

Depending upon the source material, there are a number of controls that can resolve color issues.  Without seeing an example, it is difficult to help with this.  In general, a reddish/orange cast seems to be caused by oversaturation – you might try adjusting those.  The raspivid documentation shows the various controls, including the “-br” switch.
If you are not able to get the colors close to what you like, please post the exact raspivid command that you are using for capture along with an example of what you are seeing.
If you want to use some other capture software, It is generally easier to work with the video settings through raspivid, and then use those settings in the other program.

ManuRe: Unable to Use Serial