DWQA QuestionsCategory: PiVideopivideo not finding video processor
Daniel Heiss asked 2 years ago

Hi,
I cannot get pivideo to work with the PiCapture SD Board on a RPI 3b.
I activated serial and I2C Interfaces with raspi-config and installed pivideo following your documentation. I tried all jumper settings described but always get following error no matter what interface aI choose:
Video Processor was not found – please check your jumpers and settings
Video processor not found
Are there any tricks not mentioned in your documentation how I can find out whats wrong?
Best Daniel

mwlinder Staff replied 2 years ago

No tricks – it should work!
Some suggestions:
– the I2C interface is more straightforward, because the serial port is not always free (used for the console) and it is harder to diagnose. So, I would suggest focusing on I2C to begin
– Please double-check the jumpers and make sure that they match both location and orientation
– Does the board work to capture video? The green LED on the Picapture board should be on.
– Please inspect the jumpers carefully and make sure that the metal contact inside the plastic housing is still in place for both jumpers. If they are moved around every now and then one will pull out.
– Please make sure that you have the latesst PiVideo software (1.11)

If none of this works we can work on trying to diagnose the problem.

1 Answers
mwlinder Staff answered 2 years ago

No tricks – it should work!
Some suggestions:
– the I2C interface is more straightforward, because the serial port is not always free (used for the console) and it is harder to diagnose. So, I would suggest focusing on I2C to begin
– Please double-check the jumpers and make sure that they match both location and orientation
– Does the board work to capture video? The green LED on the Picapture board should be on.
– Please inspect the jumpers carefully and make sure that the metal contact inside the plastic housing is still in place for both jumpers. If they are moved around every now and then one will pull out.
– Please make sure that you have the latesst PiVideo software (1.11)

If none of this works we can work on trying to diagnose the problem.

Daniel Heisspivideo not finding video processor