PiCapture Trouble getting PiCapture working with Raspberry PI2 model B

Tagged: 

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #708
    Joe
    Participant

    Hi,

    I received the PiCapture card today and I’ve been attempting to get it up and running but I’m hitting an issue.
    I’ve enabled the camera support and I2C support and hooked up the card to the Pi.

    When using pivideo I’m able to turn the LEDs on/off and select different sources, this appears to work as when I select the right source I get the Solid Blue LED as described in the docs. I also get the expected feedback from the command.

    However, no matter what I try it seems to fail to recognize there is a “camera” to view. I see “Raspberry Pi camera port is not active” in the pivideo output.
    I’ve tried reseating the ribbon cable multiple times and I’ve tried with 2 different Pis and I always get the same result.

    Do you have any guidance on how to proceed? Output is below for reference.

    pi@raspberrypi:~ $ pivideo –led normal –source video1 –effect none –query all -v
    Port used for video processor is: i2c1
    Source is: video1
    Effect set: none
    LED setting is: normal
    Video processor is ready
    Active video: NTSC
    Selected video source is: video1
    Active video source is: video1
    Raspberry Pi camera port is not active
    Video processor software version: 01811E
    Video processor hardware id: A89F660010429880

    pi@raspberrypi:~ $ raspivid -md 6 -awbg 1.0,1.0 -awb off -ex off -o
    mmal: mmal_vc_component_create: failed to create component ‘vc.ril.camera’ (1:ENOMEM)
    mmal: mmal_component_create_core: could not create component ‘vc.ril.camera’ (1)
    mmal: Failed to create camera component
    mmal: main: Failed to create camera component
    mmal: Camera is not detected. Please check carefully the camera module is installed correctly

    Thanks,
    Joe

    • This topic was modified 4 years ago by Joe.
    • This topic was modified 4 years ago by Joe.
    #712
    mwlinder
    Keymaster

    Hi Joe,

    Thanks for all of the debugging information and including the PiVideo and Raspivid output – it helps rule out a number of things.

    The message “Raspberry Pi camera port is not active” just means that no program (like Raspivid) is currently using, and is what is expected – we will make the documentation clearer.

    It appears that camera support has been enabled in the OS, or else PiVideo would be giving a warning message about that.

    We have found a couple of things about the GPU camera drivers in the course of our testing:
    – If you *ever* get an MMAL error, it is most likely that the camera drivers won’t work at all until there has been a reboot. One way to tell is that the red “camera active” LED doesn’t flash when attempting to start video with raspivid.
    – The error messages are frequently not very descriptive of the real problem.

    I have a few questions about your configuration:
    1) When you tested with other Raspberry Pi model B’s did you use the same SD card image or different ones?
    2) How much memory is allocated to the GPU in your configuration settings?
    3) What version of Raspbian are you using? Are you using the current GPU firmware?

    Sorry you’re having trouble getting things up and running – I’ll be glad to work through it with you to get it fixed.

    #713
    Joe
    Participant

    Hi,

    Answers are below.

    1) I tried with 2 different SDCard images, one with Wheezy and the other Jessie. Both had packages up to date.
    2) I’ve tried both 128 and 256, it doesn’t seem to make a difference
    3) As mentioned, I’ve tried Wheezy and Jessie. GPU firmware should be current as I have ran rpi-update in my attempt to solve things. See below.

    When I run raspivid command there is no change in the LED status (no LED flashes etc). The status just appears to remain constant, as shown in this video: https://youtu.be/06BvQnr0hIs

    pi@raspberrypi:~ $ vcgencmd get_camera
    supported=1 detected=0
    pi@raspberrypi:~ $ vcgencmd version
    Sep 21 2016 13:17:10
    Copyright (c) 2012 Broadcom
    version 2eaf52cc53435b5ce67253af1487f9a4f9f96e2d (clean) (release)

    Joe

    #714
    mwlinder
    Keymaster

    Thanks Joe. The red “active” LED is controlled directly by the RPi (it is driven by a logic line in the ribbon cable), and is turned on when the camera is being used. Is it on or off when you first bring up your system? Does it come on in response to a raspivid command, or at other times?

    It would be good to try the following experiment:
    — shutdown the RPi and remove power completely
    — power it on
    — the red “active” LED should be off (?)
    — run the “vcgencmd get_camera” command before doing anything else, and see if it is detected.
    — if it is detected, try “raspivid -md 6 -o” and see if there is camera output. The red “active” LED should come on then, but not before.

    #715
    Joe
    Participant

    That’s odd. This is not the behavior I am seeing. The red Active LED is solid on from the very moment I power on the board and there is never a change in that.

    See https://youtu.be/cvsz6QmTwQQ

    Joe

    #716
    Joe
    Participant

    I just tried on a raspi 3 and it worked first attempt with no issues. So at the very least it’s not a defect with the capture card itself.

    #717
    mwlinder
    Keymaster

    Thanks for the update, Joe – that’s encouraging! The hardware interface (which controls that LED) is the same, although different versions have moved the GPIO around. We’ve tested with all the different versions, and never seen the “active” LED come on at power up and so it is a bit of a mystery. I will keep working to find the problem – I think it must be something in your RPi configuration that we haven’t run into before.

    #729
    mwlinder
    Keymaster

    Joe, could you tell me if you have any other software installed on your RPi that might be controlling I/O? I suspect that whatever is turning on the GPIO line that controls the “camera active” LED is doing other things that are preventing the camera interface from working on your PI2. If it is incompatible with the PiCapture then it would be a problem for the Raspberry Pi Camera as well, but I haven’t been able to find anything in the forums that describes this symptom.

    #730
    Joe
    Participant

    I’ve been doing some more investigation and the good news is that I think it’s defective hardware on the Pi side of things.

    I’ve tried the PiCapture with several Pis (2B and 3) now, and it appears to work in all cases with the same software/sd card except with the 2 I initially tried. They also exhibit the same behavior with the Pi Camera, so it’s not unique to the PiCapture.
    The 2 in question appear to be from the same batch in 2014, so I am thinking a hardware defect might be to blame.

    Whatever the cause, I think it’s safe to say that they are not operating as intended given the behavior is present with the PiCamera as well.

    • This reply was modified 4 years ago by Joe.
    #732
    mwlinder
    Keymaster

    Thanks for the followup, Joe. I’m going to consider this “closed” then.
    I appreciate all the feedback.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.
JoeTrouble getting PiCapture working with Raspberry PI2 model B