PiCapture Strange error, still records video.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #1591
    errpoulos
    Participant

    So I ran the command
    pivideo -q all -v

    and the results were as follows.
    PiVideo Version 1.13
    Port used for video processor is: i2c1
    PiCapture SD1 is NOT READY
    No active video detected
    Selected video source is: auto
    Active video source is: auto
    Raspberry Pi camera port is not active
    Video processor firmware version: 00-000000
    Video processor hardware id: 0000000000000000

    Question 1: I am wondering if the firmware and hardware versions are supposed to be like this?

    in addition, when I run the following commands:
    raspivid -o newvid.h264 -k -rf rgb -pf high -drc low -sa -50 -vs -br 40 -fps 30 -b 120000000
    MP4Box -add newvid.h264 newvid.mp4 -fps 32
    omxplayer newvid.mp4

    I still end up with the mp4 file I expect, but end up with the following errors:

    mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board
    AVC-H264 import – frame size 1920 x 1080 at 32.000 FPS
    AVC Import results: 7 samples – Slices: 1 I 6 P 0 B – 0 SEI – 1 IDR
    Saving newvid.mp4: 0.500 secs Interleaving
    Video codec omx-h264 width 1920 height 1080 profile 100 fps 32.000000
    Subtitle count: 0, state: off, index: 1, delay: 0
    V:PortSettingsChanged: 1920×1080@32.00 interlace:0 deinterlace:0 anaglyph:0 par:1.00 display:0 layer:0 alpha:255 aspectMode:0

    The pi’s camera module is definitely enabled, I reinstalled the OS and all of the hardware just to be sure, and I also triple checked the camera ribbon connections.

    Question 2: Why am I still getting MMAL errors and the no data received error? Any ideas?

    #1604
    mwlinder
    Keymaster

    The PiVideo output is quite odd, perhaps as a result of communications errors. It reports that there is no active video detected – is the blue LED lit when you attempt the capture? If the blue LED is not lit, you will always receive an MMAL error.

    Does PiVideo give the same output each time you run the “-q all” command?

    It would be helpful if you could describe what the status LEDs look like with video input connected.

    Also, please not that you should specify “mode 6” video (640×480) with the SD1 board. You will get unpredictable results if the camera mode does not match the resolution of the video.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
errpoulosStrange error, still records video.