PiCapture Qs about PiCapture HD1

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #1385
    oralbertr
    Participant

    Hi,

    I’ve just got myself a PiCapture HD1 card and trying to play with it. Have a couple of questions, and would appreciate if someone can clarify them:

    1. ASICs on PiCapture HD1 seem to get pretty hot. Even if there’s no input video signal. Is there any way to power off/on PiCapture HD1 while still keeping Pi up and running? Any sleep mode I can put PiCapture HD1 in when it’s not being used?

    2. I’m experiencing quality issues when capturing in 1080p mode (posted another message with details) and would like to try to switch PiCapture HD1 to 720p mode. My video source (Panasonic HC V-770) doesn;t allow me to force 720p on HDMI output, but I can set to “auto” (negotiating?). However, if I do so, then PiCapture HD1 switches to 480p mode. Is there any way to force PiCapture HD1 card to 720p mode?

    Any help is greatly appreciated!

    -albertr

    #1387
    mwlinder
    Keymaster

    The current firmware for PiCapture does not implement a “sleep” or “low power” mode. We have considered adding this if it is needed by our customers.

    The PiCapture HD1 operates on the video that is provided, and so what is really needed is a way to force your source (Panasonic HC V-770) to 720p mode. If your device honors the EDID information, then one possibility is to use a custom EDID block that does not include 1080p as a valid resolution.

    The PiVideo software includes a function to load a custom EDID block. You can create custom EDID files using a software EDID editor such as AW EDID Editor

    Here is an EDID block that may work for you:
    hd1-edid-720p

    Not all source devices will honor the EDID settings, and if your device does not support 720p it will default to some other resolution.

    #1391
    oralbertr
    Participant

    Thank you for quick response! I think it would be great to have sleep and/or power off mode implemented. I.e. when there’s no active input signal, device go into sleep mode automatically and then wake up every second or so to check for the signal. And power-off/on mode would be very handy too if it can be controlled from the software (i.e. from pivideo).

    I’ve tried to load this EDID file with pivideo (please see below), but it didn’t seem to help. Panasonic HC-V770 still negotiates to mode 6 (480p). Is there any way to enable debug messages on PiCapture HD1 card, so I can see it can give any clues?

    pi@pi:~ $ pivideo –edid hd1-edid-720p.bin
    pi@pi:~ $ pivideo -q all -v
    PiVideo Version 1.12
    Port used for video processor is: i2c1
    PiCapture HD1 is ready
    Active video: Mode 6
    Selected video source is: hdmi
    Active video source is: hdmi
    Raspberry Pi camera port is not active
    Frame skip is Off
    Video processor firmware version: 05-85C103
    Video processor hardware id: 18A4660010429880
    pi@pi:~ $

    -albertr

    • This reply was modified 2 years, 11 months ago by oralbertr.
    • This reply was modified 2 years, 11 months ago by oralbertr.
    #1395
    oralbertr
    Participant

    On a side note, I’ve noticed that I cannot power off my Pi 3 now when PiCapture card is installed. Looks like it hangs somewhere at the end of the shutdown sequence.
    Reboot works, but during reboot the PiCapture card is not being reset, i.e. if I load a custom EDID block to the card, it survives reboot. Is there any way to force resetting the card from the software?

    -albertr

    #1396
    mwlinder
    Keymaster

    This is entirely a function of your camera, and so there isn’t any information available to the HD1.

    I took a quick look at your camera manual, and it appears that in order to play back at 720p you would need to record at that resolution. We can only deal with the video data being provided by the source, and other than the EDID information there is no interaction.

    #1397
    mwlinder
    Keymaster

    I’m not sure what might be preventing a shutdown – that isn’t a problem we’ve seen, and I would suspect it has something to do with your Raspberry Pi configuration or other software running.

    You can force a reset of the PiCapture board using: “pivideo –command 0401000400000000”. An alternative would be to simply re-load the original EDID block.

    #1407
    oralbertr
    Participant

    Just want to provide a quick update… I was not able to find a way to force Panasonic camcorder to output 720p on HDMI port (even if recording is set to 720p, camcorder was still outputting video in 480p on HDMI) , so I had to switch to Sony camcorder. Sony has a menu option to force HDMI output to 720p and it works fine with PiCapture.
    One thing I’ve noticed is that somehow PiCapture prefer composite input over HDMI and it doesn’t detect 720p HDMI signal from Sony camcorder unless I set source explicitly from “auto” to “hdmi”, i.e.:

    pi@pi:~ $ pivideo -q all -v
    PiVideo Version 1.12
    Port used for video processor is: i2c1
    PiCapture HD1 is ready
    No active video detected
    Selected video source is: auto
    Active video source is: component
    Raspberry Pi camera port is not active
    Frame skip is Off
    Video processor firmware version: 05-85C103
    Video processor hardware id: 18A4660010429880
    pi@pi:~ $ pivideo –source hdmi
    pi@pi:~ $ pivideo -q all -v
    PiVideo Version 1.12
    Port used for video processor is: i2c1
    PiCapture HD1 is ready
    Active video: Mode 5
    Selected video source is: hdmi
    Active video source is: hdmi
    Raspberry Pi camera port is not active
    Frame skip is Off
    Video processor firmware version: 05-85C103
    Video processor hardware id: 18A4660010429880
    pi@pi:~ $

    It’s really not a big deal, since it can be automated.
    I still observing an issue when Raspberry Pi 3 doesn’t power off with PiCapture card installed. Does anyone else experience this issue?

    -albertr

    #1413
    oralbertr
    Participant

    Actually, I was wrong about the power off issue, the raspberry Pi 3 powers off fine, I guess I was just confused that PiCapture card stays on.

    -albertr

    #1702
    tcdavolt
    Participant

    I am also looking to force 720p from my source. I tried using the EDID file provided in a previous comment, but am receiving an error as follows:

    Traceback (most recent call last):
    File “/usr/local/bin/pivideo”, line 11, in <module>
    sys.exit(main())
    File “/home/pi/.local/lib/python3.5/site-packages/pivideo.py”, line 214, in main
    edid_control(vid,args.edid)
    File “/home/pi/.local/lib/python3.5/site-packages/pivideo.py”, line 253, in edid_control
    bvalue = edidfile.read(1)
    File “/usr/lib/python3.5/codecs.py”, line 321, in decode
    (result, consumed) = self._buffer_decode(data, self.errors, final)
    UnicodeDecodeError: ‘utf-8’ codec can’t decode byte 0xff in position 1: invalid start byte

    It seems like Python 3 encoding doesn’t like something about that EDID file. Does anyone mind uploading a new one or giving me some guidance on how to create my own?

    #1705
    mwlinder
    Keymaster

    Please start a new question if you are having Python 3 issues.

    #1792
    photomatto
    Participant

    I found a work around, although it cost me an extra $22, but it does seem to solve the issue of my Canon Vixia HF R800 seeing the PiVideo HD as a 480p device. It’s called the “FUERAN HDMI Pass-Through EDID Emulator for use with Video splitters, Switches and Extenders (fit-Headless) 1920X1080@59hz”. I need to do more extensive testing but plugging it in between my camcorder and the PiCapture HD 1 has successfully locked the PiCapture HD 1 into Mode 1 1080p. And the camcorder is outputting 1080p signal. So yay!

    #1811
    photomatto
    Participant

    Here’s an update on the Raspberry Pi live streaming computer using the PiCapture HD1 to capture video from my Canon Vixia HF 800. I was able to live stream an entire youth soccer game in 1080P to YouTube with the setup. I’m working on a “how to” post and I’ll update this thread when that’s done, but here a link to the video. I still have a slight audio sync issue of ~<1 sec and I feel that the video is a little hot on the red color but totally watchable and *way* higher quality than steaming using my iPhone 8+ and the YouTube app. This has been a big upgrade. The PiCapture HD1 is a champ and performed flawlessly. Here’s the video link: https://youtu.be/zYW2PE5MBPY

    #1812
    mwlinder
    Keymaster

    Thanks for the update, and for posting the video – it looks great! We are looking forward to the details of the how-to post.

    #1948
    photomatto
    Participant

    I’ve finished my Parts List and Build Guide for the Raspberry Pi streaming setup. I’d welcome any feedback as I see this as a work in progress. I’ve really been enjoying using the PiCapture HD1 and feel that I’m getting solid performance and excellent video quality from the system.

    Here’s a link to the guide.

    Thanks!

    #1949
    mwlinder
    Keymaster

    Thank you very much for putting this together! It is very clear and would be helpful to others working with PiCapture – Would it be OK to post a link to your guide?

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.
oralbertrQs about PiCapture HD1