PiCapture PiCapture SD1 incomptability issue through RTSP stream

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #1971

    I have some issues to use the PiCapture SD1..
    Indeed i’m trying to stream a rtsp flux through SD1. My camera is plugged into the composite output.
    I tried many things :
    – My camera works with the command : raspivid -md 6 thus I suppose that my raspberry PI3 has the right driver.
    – I tried to stream the RTSP stream using v4l2rtspserver (https://github.com/mpromonet/v4l2rtspserver) but the video is cropped with a lot of noise.
    – I tried to use the driver (uv4l,http://www.linux-projects.org/uv4l/installation/) unsing cvlc (https://www.linux-projects.org/uv4l/tutorials/rtsp-server/) . It worked whitout the SD1 (with the official raspberry pi camera) but if I add it I have some issues in the terminal :
    It said that the video inout is opened but nothing works and I get these warnings :
    “obsub demux debug : this doesn’t seem to be a vobsub file , ps demux warning : this does not look like an
    MPEG PS stream , continuing anyway”
    “garbage at input from 509,trying to resync”

    I do not see other solutions and I’m stuck, consequently I hope you could help me or give me some help. I suppose that it’s a comptability issue.
    Is there a special driver or a special config which allows the use of the SD1 ? or is there another way to get my RTSP video stream ?

    I look forward to your future help,



    You do not need any special driver to use PiCapture – it emulates the Raspberry Pi camera, and so anything that works with the RPi camera will work with the SD1. The most likely issue is that you are not configuring things on the RTSP side to match the “Mode 6” video. You mention that you have streaming working with the RPi camera, but you need to be certain that the resolution matches Mode 6 (640×480). If there is a mismatch, you will get errors such as what you are seeing.

    The guide published Here is for an HD1 operating with “Mode 1” video, but could be a starting point. If you use Raspivid for the capture portion, then you know that any errors are after that step.


    First of all, I would like to thank you for your rapidity and your response. Thanks to it, I succeeded to find the problem and solve it. It’s was not a case of wrong driver but wrong settings. Indeed I had a faulty frame/s.


Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
maxime.redfieldPiCapture SD1 incomptability issue through RTSP stream